debian swirl logo

Back to the packages list libplack-middleware-file-sass-perl

#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-
# Copyright 2011, Jonas Smedegaard 
# Description: Main Debian packaging script for Plack::Middleware::File::Sass
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2, or (at your option)
# any later version.
#
# This program is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see .

include /usr/share/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/perl-makemaker.mk
include /usr/share/cdbs/1/rules/debhelper.mk

DEB_UPSTREAM_PACKAGE = Plack-Middleware-File-Sass
DEB_UPSTREAM_URL = http://www.cpan.org/modules/by-module/Plack
#DEB_UPSTREAM_URL = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA
DEB_UPSTREAM_TARBALL_MD5 = dd1d45cdda21e22d245901dc62d3fbca

# Needed both by upstream build process and at runtime
common-depends = libplack-perl

# Text::Sass provides only a limited Sass implementation, so the Ruby
# implementation is recommended even when Text::Sass is available
CDBS_BUILD_DEPENDS += , $(common-depends), libtest-requires-perl, libtext-sass-perl
CDBS_DEPENDS_ALL = $(common-depends), ruby-sass | libhaml-ruby (<< 3.1) | libtext-sass-perl
CDBS_RECOMMENDS_ALL = libhaml-ruby

Builds:

libplack-middleware-file-sass-perl
sass and scss support for all plack-based psgi frameworks